George James Software logo

KB0115

Caché Control Panel's Process Debug Facility is Unavailable on Some Platforms

Applies to: Serenji on Caché 3.x and 4.x

Symptoms

When connecting to Caché on Windows, debugging with Serenji can be initiated by right-clicking on the user process in the Caché Control Panel, and choosing "Debug".

However, when Caché Control Panel connects to a non-Windows based server, the "Debug" option fails to interrupt the process and connect it to Serenji.

Cause

Prior to Caché 5, Control Panel's Process Debug feature has not been implemented for non-Windows Caché servers. This functionality is supplied by InterSystems and is not available irrespective of whether Serenji is installed or not.

Solution

Upgrade to Caché 5.

Note

In order for Serenji to exploit the Process Debug facility, the appropriate one of the following conditions must be satisfied:

Otherwise, Caché's default command-line debug facility will be triggered.

Last reviewed: Nov 15, 2004

Back to top